欢迎光临
让更多人用上统信UOS系统

如何在 AlmaLinux 8 上安装 Ruby on Rails

Ruby on Rails 或 Rails 是一个用 Ruby 编程语言编写的开源 Web 应用程序开发框架。Rails 是一个服务器端 Web 应用程序框架,可促进 Web 标准的使用。它是一个使用模型-视图-控制器 (MVC) 模式的全栈 Web 框架。GitHub、Crunchbase、Bloomberg 等知名组织都在使用 Ruby on Rails。ruby_and_rails_logo

在 AlmaLinux 8 上安装 Ruby on Rails

第 1 步。首先,让我们首先确保您的系统是最新的。

sudo dnf clean all
sudo dnf install gnupg2 curl
sudo dnf update

步骤 2. 在 AlmaLinux 8 上安装 Ruby。

默认情况下,Ruby 在 AlmaLinux 8 基础存储库中不可用。现在我们运行以下命令将 (RVM) Ruby 版本管理器安装到您的系统:

curl -sSL https://get.rvm.io | bash

安装完成后,将普通用户添加到 RVM 组,如下所示:

adduser idroot
usermod -aG rvm idroot

接下来,通过执行命令更新系统环境变量:

source /etc/profile.d/rvm.sh

让我们使用以下命令重新加载 RVM 以使更改生效:

rvm reload
rvm requirements

在此之后,我们现在需要检查可用的 Ruby 版本,然后我们安装可用的最新版本:

rvm list known

输出:

[ruby-]1.8.6[-p420]
[ruby-]1.8.7[-head] # security released on head
[ruby-]1.9.1[-p431]
[ruby-]1.9.2[-p330]
[ruby-]1.9.3[-p551]
[ruby-]2.0.0[-p648]
[ruby-]2.1[.10]
[ruby-]2.2[.10]
[ruby-]2.3[.8]
[ruby-]2.4[.10]
[ruby-]2.5[.9]
[ruby-]2.6[.9]
[ruby-]2.7[.5][ruby-]3[.0.3]
[ruby-]3.1[.0-preview1]
ruby-head

在编写本指南时,最新的可用 Ruby 版本是 3.0.3。要使用 RVM 管理器安装 Ruby,请运行以下命令:

rvm install ruby 3.0.3

要使上述版本成为 Ruby 的默认版本,请运行以下命令:

rvm use 3.0.3 --default

检查 Ruby 版本:

ruby --version

步骤 3. 在 AlmaLinux 8 上安装 Rails。

现在是在 AlmaLinux 8 系统上安装 Rails 的时候了。我们可以使用以下gem命令方便地做到这一点:

gem install rails

验证 Rails 版本:

rails --version

感谢您使用本教程在您的 AlmaLinux 8 系统上安装 Ruby on Rails 开源 Web 应用程序框架。如需更多帮助或有用信息,我们建议您查看官方 Ruby on Rails 网站

赞(0) 打赏
未经允许不得转载:统信UOS之家 » 如何在 AlmaLinux 8 上安装 Ruby on Rails

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏