欢迎光临
让更多人用上统信UOS系统

如何在 Ubuntu 22.04 LTS 上安装 Yarn

Yarn 是一个与 npm 兼容的 JavaScript 包管理器,可帮助您自动化安装、更新、配置和删除 npm 包的过程。它是任何其他 Nodejs 包管理器的快速、安全和可靠的替代方案。yarn-logo

在 Ubuntu 22.04 LTS Jammy Jellyfish 上安装 Yarn

apt步骤 1. 首先,通过在终端中运行以下命令,确保所有系统包都是最新的。

sudo apt update
sudo apt upgrade

步骤 2. 安装 Node.js。

默认情况下,Node.js 在 Ubuntu 22.04 基础存储库中不可用。现在运行以下命令将 NodeSource 存储库添加到您的 Ubuntu 系统:

wget -qO- https://deb.nodesource.com/setup_16.x | sudo -E bash

将 NodeSource 存储库添加到系统后,使用 Apt 包管理器安装 Node.js:

sudo apt install nodejs

使用以下命令检查 NPM(节点包管理器)的版本:

npm -v

步骤 3. 在 Ubuntu 22.04 上安装 Yarn。

默认情况下,Yarn 在 Ubuntu 22.04 基础存储库中不可用。现在运行以下命令将 Yarn 安装到您的 Ubuntu 系统:

sudo npm install -g yarn

确认安装并检查已安装的 Yarn 构建版本:

yarn --version

步骤 3. 使用纱线。

成功安装 Yarn 后,您就可以开始使用 Yarn。以下是您需要的一些最常见的命令:

使用 yarn init 创建一个新的 Yarn 项目:

yarn init idroot_yarn_project

添加依赖:

yarn add [package_name]

将依赖项添加到不同类别的依赖项:

yarn add [package] --dev
yarn add [package] --peer
yarn add [package] --optional

升级依赖:

yarn upgrade [package_name]
yarn upgrade [package_name]@[version_or_tag]

删除依赖项:

yarn remove [package]

安装项目的所有依赖项:

yarn

感谢您使用本教程在 Ubuntu 22.04 LTS Jammy Jellyfish 系统上安装 Yarn 包管理器。如需更多帮助或有用信息,我们建议您查看Yarn 官方网站

赞(0) 打赏
未经允许不得转载:统信UOS之家 » 如何在 Ubuntu 22.04 LTS 上安装 Yarn

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏